VMware Workstation and Device/Credential Guard are not compatible

1. 问题导入

在win10系统中,如果启用了Hyper-V这个自带的虚拟机,当再次使用VMware时就会遇到VMware Workstation and Device/Credential Guard are not compatible的错误提示,无法使用VMware

2. 原因分析

启用了Hyper-V,就会开启微软自带的hypervisor,也就是这个程序启动了Credential Guard导致VMware无法启动。

3. 如何解决

因此,我们只需关闭hypervisor,即可关闭Credential Guard

以管理员身份运行cmd,输入

1
bcdedit /set hypervisorlaunchtype off

然后重启系统就可以了

4. 类似的

如果今后发现需要启用的话,同样以管理员身份运行cmd,输入

1
bcdedit /set hypervisorlaunchtype auto

重启系统即可。